ODBC Datenquelle-keine Netzlaufwerke

Fragen, Vorschläge, Anforderungen, Diskussion zu Untis MultiUser
Antworten
noid
Beiträge: 2
Registriert: 20. November 2015, 09:22

ODBC Datenquelle-keine Netzlaufwerke

Beitrag von noid » 20. November 2015, 09:31

Hallo,

wir betreiben eine Untis Multiuser Installation. Die Clients sind Win7/64bit. Die Untis DB liegt auf einem Netztlaufwerk am Server. Wenn ich die ODBC Datenquelle erstellen möchte unter
c:\Windows\Syswow64\odbccad32
gehe ich auf hinzufügen Microsoft Access Treiber dann wähle ich Microsoft Access Treiber aus dann Datenquellenname Untis und dann kommt
das Problem unter Datenbank auswählen klicke ich auf Laufwerke und es werden keine Netzlaufwerke angezeigt.
Die Netzlaufwerke sind aber verbunden und der Zugriff darauf im Explorer funktioniert ohne Probleme.

Kennt jemand dieses Problem? Tritt nur bei einem neuen Laptop auf, ansonsten funktioniert es genau so bei allen meinen Rechnern.

Danke im voraus für jede Hilfe.

Grüße

Arnold

kroerig
Beiträge: 249
Registriert: 1. September 2008, 21:08
Kontaktdaten:

Re: ODBC Datenquelle-keine Netzlaufwerke

Beitrag von kroerig » 27. November 2015, 17:56

Hallo!

Das liegt am Wechsel in den "privilegierten Modus" (= als Administrator ausführen)

Es gibt zwei Möglichkeiten:

1. Vor dem Start von odbc32 verbinden sie das Netzlaufwerk mit "net use LW: \\server\freigabe"

2. Legen Sie unter "HKLM:\Software\Microsoft\Windows\CurrentVersion\Policies\System" einen REG_DWORD "EnableLinkedConnections" mit Wert 1 an. Dann werden im User-Context verbundenen Laufwerke auch im piv. Modus beibehalten.

Klaus Rörig

PS: da 2 ein Sicherheitsrisiko sein kann, würde ich 1 machen. So oft braucht man das ja normal nicht.
IT-Service Klaus Rörig
IT Dienstleistungen im Bergischen Land

noid
Beiträge: 2
Registriert: 20. November 2015, 09:22

Re: ODBC Datenquelle-keine Netzlaufwerke

Beitrag von noid » 2. Dezember 2015, 11:50

Hallo,

der Benutzer arbeitet auf einem Laptop und ist mit einem Administrator Account angemeldet. Deswegen sollte er eigentlich
im privilegierten Modus laufen.

Punkt 1. hat nichts genutzt.

Punkt 2. hat funktioniert!!!

Vielen vielen Dank für die Hilfe, das hätte ich alleine nie gefunden.

Grüße

Arnold

kroerig
Beiträge: 249
Registriert: 1. September 2008, 21:08
Kontaktdaten:

Re: ODBC Datenquelle-keine Netzlaufwerke

Beitrag von kroerig » 2. Dezember 2015, 15:06

noid hat geschrieben:Hallo,

der Benutzer arbeitet auf einem Laptop und ist mit einem Administrator Account angemeldet. Deswegen sollte er eigentlich
im privilegierten Modus laufen.
Nein, ab Windows Vista ist ein Administrator kein Administrator mehr. Er hat lediglich das Recht sich Admin-Rechte holen zu dürfen, wenn sie erforderlich sind. Wann das erforderlich ist, wird über die UAC geregelt.

Der übliche Weg odbcad32.exe zu starten ist über eine cmd mit administrativen Rechten. Wenn Sie dort vor dem Start von odcbad32.exe das Netzlaufwerk verbinden klappt das.

Klaus Rörig
IT-Service Klaus Rörig
IT Dienstleistungen im Bergischen Land

Antworten