Seite 1 von 1

MultiUser2015 - Kein Aufbau zur Datenbank

Verfasst: 7. November 2014, 15:13
von Manfred Neumann
Wir haben seit einigen Schuljahren die MultiUser-Version mit einer MS SPQ-Server Datenbank und entsprechend eingerichteten Clients.
Nun ist einerseits ein neuer Rechner W7 64bits (mit bestehenden Untis-Benutzer) und neue Benutzer (an bestehenden Rechnern) hinzugekommen.
Die ODCB-Verbindungen wurden alle laut Anweisung eingerichtet.
Installation als Administrator.
Nun lässt mich folgendes Problem verzweifeln:
Sowohl die Verbindung vom neuen PC (mit bestehenden Benutzer), als auch die Verbindung von neuem Benutzer (an bestehenden Rechner) zur Untis-Datenbank werden nicht aufgebaut.
Es startet zwar Untis, aber danach kommt eine Datenbank-Login-Abfrage, die keine bekannten Eingaben zulässt.
Es dürfte sich wohl um ein Berechtigungsproblem an der Datenbank handeln?
Weiß jemand Abhilfe?

Re: MultiUser2015 - Kein Aufbau zur Datenbank

Verfasst: 11. November 2014, 08:05
von gg
Spontan fallen mir zwei Punke ein, die Sie checken können:

Falls in der ODBC-Verbindung die Option "With SQL Server authentication ..." gewählt wurde, müssen Untis der MS SQL Benutzername und das Passwort (die beiden haben nichts mit jenen Usern und Passwörtern zu tun, die Sie später für das Arbeiten in Untis verwenden) mitgeteilt werden. Dies erfolgt über den MultiUser-Einstellungsdialog, den Sie im Tab Module im MultiUser-Bereich finden. Sie müssen, damit er anwählbar ist, entweder eine Demo-Datei oder eine gpn-Datei mit MultiUser-Lizenz laden.

Bitte werfen Sie auch einen Blick in die Datenbank selbst. In MS SQL hat jede Tabelle einen Table Owner, mittels dem festgelegt wird, wer sie überhaupt sehen und bearbeiten darf und wer nicht (standardmäßig wäre das "dbo", im Prinzip kann es aber jeder sein). Das heißt, dass einem Client-Rechner, der mit einem anderen Login auf die Datenbank zugreift, die Tabellen erst gar nicht zur Verfügung stehen.